1. SPS Accounts:
    Do you find yourself coming back time after time? Do you appreciate the ongoing hard work to keep this community focused and successful in its mission? Please consider supporting us by upgrading to an SPS Account. Besides the warm and fuzzy feeling that comes from supporting a good cause, you'll also get a significant number of ever-expanding perks and benefits on the site and the forums. Click here to find out more.
    Dismiss Notice
Dismiss Notice
You are currently viewing Boards o' Magick as a guest, but you can register an account here. Registration is fast, easy and free. Once registered you will have access to search the forums, create and respond to threads, PM other members, upload screenshots and access many other features unavailable to guests.

BoM cultivates a friendly and welcoming atmosphere. We have been aiming for quality over quantity with our forums from their inception, and believe that this distinction is truly tangible and valued by our members. We'd love to have you join us today!

(If you have any problems with the registration process or your account login, please contact us. If you've forgotten your username or password, click here.)

ALT-Tab from IWD2 (and other games)

Discussion in 'Icewind Dale 2' started by myrrh, Aug 12, 2016.

  1. myrrh Gems: 1/31
    Latest gem: Turquoise


    Joined:
    Aug 12, 2016
    Messages:
    7
    Likes Received:
    1
    Below are instructions for how to ALT-TAB from the GOG version of Icewind Dale II in Windows. This method may also work with other games that refuse to let the user ALT-TAB and insist on always being on top no matter what. An explanation for the motivations for doing this and other approaches follow the method.

    The simplest method is to make another window always-on-top. Then you'll be able ALT-TAB from IWD2 to the other always-on-top window, and back again. (Note: you may have to click on the IWD2 window once you return to it, to fully activate it again)

    Now, how can one make a window stay always on top? There are many ways to do it in Windows. One of the easiest is to use a utility program exclusively designed for this, such as aptly named "Window On Top" app, or perhaps some others.

    Another way is to use this autohotkey script:

    Code:
    ; Type Control-F8 to make the in-focus window toggle state
    ; between being always on top and not always on top.
    ;
    ^F8::
      Winset, Alwaysontop, Toggle, A
    Return
    
    (Please be aware that I've only tested this script in Windows 8.1. It may or may not work in other Windows versions.)

    One problem with this always-on-top window method is that you may want to access multiple windows, not just one, and then the one window which you've made be always-on-top may obscure other windows which you want to use.

    The solution to the above problem that I've found is to use a virtual desktop management app like VirtuaWin to keep each window that I want to access from IWD2 on a seperate desktop, and then switch to that desktop using a keyboard shortcut I've configured in VirtuaWin. (For some reason, the default "NAV:Move left" and "NAV:Move right" VirtuaWin shortcuts weren't working very well for me, so I bound the "NAV:Move next" and "NAV:Move previous" commands instead, and those work great) Another solution could be to make multiple windows always-on-top and keep them on the same desktop, but then their size needs to be limited so that they don't obscure each other. I like the VirtuaWin solution better myself. One last potential solution is to run IWD2 in a virtual machine, such as with VirtualBox. I currently don't have that luxury. So I had to make it work natively in my host Windows OS.

    Now for the motivation for all this and the other solutions I've tried, which have all failed.

    First, the reason why I did this. The usefulness of being able to switch to other applications from should really need no explanation. For IWD2 in particular, I desperately needed to be able to read strategy guides while I played, and it was really impractical to have to quit the game any time I needed to refer to them an drestart it again after I was done, relying on my memory of what I had to do. This is even impossible to do at some parts of the game, such as during character creation or while leveling up. So I had to find a solution.

    Things I tried:

    A) Using ALT-ENTER to switch to windowed mode. This simply does nothing.

    B) Turning the "Full screen" toggle off inside the "Graphics" section of the configuration within the game itself. When I do this, it always switches back to the "on" state when I return to the configuration and simply does not work.

    C) Using the config utility in the IWD2 folder to switch the "Windowed" mode on. The checkmark stays, but it has no effect. By the way, I should mention that I only tried this after installing the widescreen mod, so perhaps that's why this setting is ignored. But I doubt it, as in my research I see many other GOG games have the same problem, and I think GOG does something to force their games always-on-top to try to avoid some compatibility problems.

    D) Various compatibility mode settings for the IWD2 shortcut.

    E) Appending -window or -swindow to the "Target:" field in the IWD2 shortcut.

    F) Running "sdbinst -u game.sdb" in the IWD2 directory. (There is no "game.sdb" file in there for "sdbinst" to work on. I actually didn't try this, but I don't think it will work, for the above reason. Also, I don't want to mess with the game if I don't know of a way to bring it back to the way it was, and here I wouldn't know how to reverse the effects of this sdbinst command, except to uninstall and reinstall the game, maybe)

    So there you have it. The fruit of a full day's work. I hope someone else can benefit from my efforts.

    If anyone has a better/easier solution that works on Windows 8.1, with the GOG version of IWD2, I'd love to hear it.






    keywords: alt-tab, alt+tab, windows, switching, iwd2, icewind dale, can't alt-tab, won't alt-tab, infinity engine, gog, good old games, full screen
     
    Taluntain likes this.
  2. henkie

    henkie Hammertime Resourceful Adored Veteran New Server Contributor [2012] (for helping Sorcerer's Place lease a new, more powerful server!)

    Joined:
    Jan 13, 2006
    Messages:
    2,607
    Media:
    38
    Likes Received:
    151
    Gender:
    Male
    Is this a Windows 8.1 problem? I run the GoG version of IWD2 in windowed mode without problems, works just like BG2.
     
  3. Keneth Gems: 28/31
    Latest gem: Star Sapphire


    ★ SPS Account Holder Resourceful Adored Veteran

    Joined:
    Jul 22, 2002
    Messages:
    2,980
    Likes Received:
    197
    Gender:
    Male
    I don't know know why you have these problems, I've always been able to put the game into windowed mode, both via the settings and using alt+enter. But I do admit that IWD2 code is poorly written and playing it on a shitty OS like Win8 only exacerbates the problem. Not being able to alt-tab normally has always annoyed me too.
     
  4. myrrh Gems: 1/31
    Latest gem: Turquoise


    Joined:
    Aug 12, 2016
    Messages:
    7
    Likes Received:
    1
    I'm not sure if this is a Win 8.1 problem, as I don't have any other versions of Windows to test on. But I'm definitely not the only one experiencing this problem. Here are a couple of others: [1][2]. The second of these is from 2005, using Windows XP.

    Also, from my research, I see that this is a very common problem with GOG games. I can't find it now, but I could swear I saw in a FAQ somewhere GOG admitting that they modify games deliberately to prevent ALT-TAB as a way of preventing some issues. Perhaps the version of IWD2 that you have does not have this modification for some reason. Maybe GOG just started doing this for IWD2 recently, as I just got it recently myself, and I'd guess that most of the people on here have been playing IWD2 for a long time, and so have older versions. Or maybe the problem is caused by some combination of patches, configuration settings, or OS version/tweaks on my end. It's all conjecture at this point, unfortunately. But if anyone else is having the same issue, that's the solution that's worked for me.
     
  5. Keneth Gems: 28/31
    Latest gem: Star Sapphire


    ★ SPS Account Holder Resourceful Adored Veteran

    Joined:
    Jul 22, 2002
    Messages:
    2,980
    Likes Received:
    197
    Gender:
    Male
    My game version is only a few months old. And yeah, GOG does disable alt-tabbing occasionally because it's problematic. It's usually a lazy and heavy-handed fix.
     
  6. henkie

    henkie Hammertime Resourceful Adored Veteran New Server Contributor [2012] (for helping Sorcerer's Place lease a new, more powerful server!)

    Joined:
    Jan 13, 2006
    Messages:
    2,607
    Media:
    38
    Likes Received:
    151
    Gender:
    Male
    Haven't had that many GoG games that disabled alt-tabbing, in fact, can't think of any. I just noticed my IWD2 installation is still from the DVD, not from GoG, so that's probably why I didn't have any problems.
     
  7. SlickRCBD Gems: 24/31
    Latest gem: Water Opal


    Resourceful Veteran

    Joined:
    May 7, 2005
    Messages:
    1,948
    Media:
    21
    Likes Received:
    81
    Gender:
    Male
    With Windows 7 and below, I've found that all you need to do to get ALT+Tab to work is have another window open to switch to before starting the game.
    This applies to just about all games that go into fullscreen mode, not just IceWind dale. I figured this out with Windows 95 and it has worked in every version since up to 7. My computer is old so I haven't tested it with newer versions as I haven't done a lot of gaming on them.

    Of course, sometimes the game will crash, or have the resolution screwed up, or have the refresh rate screwed up causing the game to appear to be shifted off the screen, or just the color palette messed up when you go BACK to the game after using ALT-Tab.
     
  8. myrrh Gems: 1/31
    Latest gem: Turquoise


    Joined:
    Aug 12, 2016
    Messages:
    7
    Likes Received:
    1
    I've had windows open before starting the game, and IWD2 still does not let me ALT-Tab to them.

    To be a bit more precise in describing the symptoms, I think the other windows are accessible through ALT-Tab, but IWD2 insists on being in the foreground, so it obscures the view of the other windows and clicking anywhere on the screen returns focus to IWD2 itself and resumes the game (the game music starts playing again, for instance). But, curiously, when I do ALT-Tab to another window, I can still interact with the window through the keyboard, just not by clicking the mouse.

    Another weird thing is that I can actually see thumbnails of the other windows by hovering over their icons in the Windows task bar after an ALT-Tab from IWD2, and hovering over one of these thumbnails lets me see the full-sized window while my mouse pointer remains over the thumbnail, but as soon as I click on the thumbnail or move the mouse pointer away from it, the full-sized window disappears and I only see the IWD2 screen again, and clicking anywhere else just resumes the IWD2 game itself. It's only by hovering the mouse over these thumbnails that I can see the effect of my typing in to these windows, but as soon as I type a single keystroke while hovering over them, the full-sized view of that window disappears and the IWD2 screen reappears again.

    So, what that amounts to is that ALT-Tab is almost completely broken for me, unless I use the solution I described in my first post.
     
Sorcerer's Place is a project run entirely by fans and for fans. Maintaining Sorcerer's Place and a stable environment for all our hosted sites requires a substantial amount of our time and funds on a regular basis, so please consider supporting us to keep the site up & running smoothly. Thank you!

Sorcerers.net is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to products on amazon.com, amazon.ca and amazon.co.uk. Amazon and the Amazon logo are trademarks of Amazon.com, Inc. or its affiliates.